Overheating Ampeg SVT 4 Pro

General discussion area for tube amps.

Moderators: pompeiisneaks, Structo, mhuss, HeeBGB

Post Reply
User avatar
Deric
Posts: 702
Joined: Sun Jan 14, 2007 2:56 am

Overheating Ampeg SVT 4 Pro

Post by Deric » Thu Mar 10, 2011 10:52 pm

I have an Ampeg SVT 4 Pro here that overheats and shuts down after being pushed for 20 minutes or so. Did a quick Google and it appears to be a common issue. Any body here ever dealt with one of these?

Thanks
Deric®

Beerman
Posts: 81
Joined: Thu Mar 01, 2007 7:16 am
Location: Melbourne, Australia

Re: Overheating Ampeg SVT 4 Pro

Post by Beerman » Thu Mar 10, 2011 11:11 pm

I'm interested in this one too.

A good friend has one of these that does similar... although his will run for an hour.

It'd be nice if it was an easy fix.
__________________________________________
Cheers and Beers.

User avatar
Structo
Posts: 15451
Joined: Wed Oct 17, 2007 1:01 am
Location: Oregon

Re: Overheating Ampeg SVT 4 Pro

Post by Structo » Fri Mar 11, 2011 5:20 pm

I wonder if it has a thermal shut off device in the PT.

Takes a while to heat up (1 hour) then trips, shutting the amp off.

I have seen other amps that use those and they usually cause problems down the road.
I seem to remember some Marshall guys talking about that.

On those it was on the primary side and was pretty easy to remove.
Tom

Don't let that smoke out!

Alexo
Posts: 477
Joined: Thu Mar 22, 2007 3:27 am
Location: The Hudson Valley

Re: Overheating Ampeg SVT 4 Pro

Post by Alexo » Fri Mar 11, 2011 8:33 pm

You could try putting a fan behind it and see if it persists. If the prob goes away, maybe think about mounting one in the cab.
Life is a tale told by an idiot -- full of sound and fury, signifying nothing.

...in other words: rock and roll!

User avatar
David Root
Posts: 3540
Joined: Fri Aug 04, 2006 3:00 pm
Location: Chilliwack BC

Re: Overheating Ampeg SVT 4 Pro

Post by David Root » Sat Mar 12, 2011 12:17 am

Tom, I wouldn't be surprised if you are right. Fender briefly used those thermal shut-offs in their '70s high power bass amps. Hopefully the one here is not inside the transformer.

User avatar
selloutrr
Posts: 3705
Joined: Sun Oct 14, 2007 2:44 am
Location: Southern California

Re: Overheating Ampeg SVT 4 Pro

Post by selloutrr » Sat Mar 12, 2011 12:21 am

I've been in the 4 / 5 / and 6 pro .... Bitches to work on to put it nicely. The paste the secures to the heat sinks dries out. reference the schematic and visually look over the amp to make sure you have the correct schematic versions. You will probably need to replace the component as well if you have tried to run the amp for any period of time since the problem occured.
My Daughter Build Stone Henge

Post Reply

Who is online

Users browsing this forum: myfoot and 7 guests